Letter Metric Delays

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 09:47 EDT

Update

Things appear to be operating smoothly. There are still some metrics catching-up, but we think the underlying issue is resolved. We'll keep monitoring for awhile.
Posted Jun 04, 2025 - 12:43 EDT

Monitoring

We have patched the underlying issue, but we'll be monitoring for awhile to ensure the pace of metrics collection keeps up.
Posted Jun 04, 2025 - 11:17 EDT

Identified

We have seen a number of letters stall in the "sending" status for a prolonged period, and the underlying cause is that the metrics for those are collecting too slowly. The newsletters have already successfully sent, but our system updates the "sending" status to "published" when certain metric thresholds are met. Because those aren't being met, some of you may think that newsletters are failing to go out.

This is not the case. We've identified the problem, and we are working to address the issue.

Note: newsletters are successfully sending on time, _and_ their metrics are being collected, but our system just isn't communicating one to the other correctly. Thanks for your understanding.
Posted Jun 04, 2025 - 09:51 EDT
This incident affected: Services (Metrics).