We are crossing our t's and dotting our i's, but we ought to be finishing up here shortly. Thank you for your patience.
Posted Apr 26, 2025 - 21:04 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2025 - 20:15 EDT
Scheduled
We are performing scheduled maintenance on systems related to metrics collection. During this period, folks will notice newsletter reports will update less frequently. You will still be able to send newsletters and do everything you expect in Letterhead.
Posted Apr 26, 2025 - 20:14 EDT
This scheduled maintenance affected: Applications (Newsletters).