Isolated Tenant Upstream Connectivity Issue

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 14:27 EST

Monitoring

Everything's looking copacetic. We will monitor for awhile longer. Sorry for the fright.
Posted Mar 04, 2026 - 14:14 EST

Update

Confirming that this is affecting the affected tenant's user interface, but neither delivery nor archives
Posted Mar 04, 2026 - 13:50 EST

Investigating

We are investigating an issue causing requests for a single tenant to return upstream availability errors (“no healthy upstream”). All other tenants remain unaffected. Engineers are actively working on resolution.
Posted Mar 04, 2026 - 13:47 EST
This incident affected: Applications (Audience, Composer, Dashboards, Newsletters, Promotions).