Investigating an incident with Login
Incident Report for Letterhead
Resolved
Some customers had reported difficulty logging in to Letterhead's core application. This incident was due to a major service outage with Auth0, which affected all of their customers. 

During this time, Letterhead's core services -- archives, our email service provider, APIs, and promotions -- were unaffected.
Posted Oct 30, 2023 - 16:23 EDT