Investigating an incident with our Link Resolver
Incident Report for Letterhead
Resolved
Link Resolution is working like a gem, thanks for your patience. The issue was a conflicting web server that had erroneously spawned and was trying to steal some thunder. We corrected this problem and ensured it won't happen again. No service was interrupted.
Posted Jan 30, 2024 - 14:41 EST
Identified
Some customers are reporting difficulty using Link Resolver, in which Letterhead's "resolved" links -- those that track for promotions -- are not routing properly.. Our team is actively investigating the incident and will update you with more information within an hour.

Please check our status page and subscribe to alerts for the most up-to-date information.
Posted Jan 30, 2024 - 14:31 EST
This incident affected: Applications (Newsletters, Promotions).