Promotion tracking performance issues
Incident Report for Letterhead
Resolved
After several hours of monitoring we think things are groovy.
Posted Apr 20, 2021 - 20:36 EDT
Monitoring
We have identified performance issues related to our pixels (called "rangers") and we are performing some maintenance to improve this. You may notice incorrect views stats. This does not impact our link tracking.
Posted Apr 20, 2021 - 13:46 EDT
This incident affected: Applications (Promotions).