[Resolved] Audience Menu Glitch

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 07:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2026 - 20:18 EDT

Identified

We found the issue and we're noodling on a patch.
Posted Mar 23, 2026 - 19:50 EDT

Investigating

We're noticing that the Audience Menu isn't consistently available for channel administrators, either rendering as disabled or just not appearing at all. We're investigating the issue now.
Posted Mar 23, 2026 - 19:35 EDT
This incident affected: Applications (Audience).