Letter segments not selectable

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted May 19, 2025 - 14:55 EDT

Monitoring

People should be able to select all the segments they expect. We will monitor for a moment. Thank you for your patience.
Posted May 19, 2025 - 13:11 EDT

Identified

We have identified the underlying issue and we're applying the patch shortly.
Posted May 19, 2025 - 12:53 EDT

Investigating

We have reports from people who can't select any segment other than "Active subscribers" when scheduling a newsletter. We've been able to replicate this, and we're on the job. Your sending otherwise is unaffected, and automated newsletters will continue as normal. Apologies for this display issue.
Posted May 19, 2025 - 12:43 EDT
This incident affected: Applications (Composer).