Mailchimp Elevated Errors

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 23:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2026 - 20:32 EDT

Identified

We have identified the underlying issues and we have already deployed a patch.
Posted Mar 30, 2026 - 19:25 EDT

Investigating

We are addressing elevated errors surrounding our Mailchimp integration, particularly around sending test emails with Mailchimp. Thanks for your patience.
Posted Mar 30, 2026 - 18:43 EDT
This incident affected: Integrations (Mailchimp) and Applications (Newsletters).