Double-optin Email Confirmation Delivery - Elevated Misconfiguration Rates

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 14:37 EST

Monitoring

We addressed the underlying issue and we're keeping our eye on it.
Posted Mar 02, 2026 - 12:45 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 12:06 EST

Identified

We're seeing an elevated rate of errors related to domain misconfiguration as it relates to double-optin email confirmations.
Posted Mar 02, 2026 - 12:04 EST
This incident affected: Services (Transactional Emails).