Automation Latency

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted May 07, 2025 - 17:00 EDT

Monitoring

Automations are proceeding normally, but the latency is still at pretty high levels, so we are going to continue monitoring.
Posted May 07, 2025 - 16:33 EDT

Investigating

We are noticing increased latency during newsletter automation processing, which is causing automations to get temporarily "stuck" in a prolonged "processing" status. We are currently shifting resources to these processes so they can continue to be timely, while we solve the underlying issue. Thank you for your patience.
Posted May 07, 2025 - 16:10 EDT
This incident affected: Applications (Newsletters).