Recurring Newsletter Automation Delays

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 11:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2026 - 11:57 EDT

Identified

We are observing some delays related to recurring newsletter automations, and we have already identified the issue. While we poke the bear, some of you may have automations that error-out or are stalled in some kind of processing. If you don't intervene yourself, we will ensure everything gets reoriented shortly. Thank you for your patience.
Posted Jul 06, 2026 - 10:30 EDT
This incident affected: Services (Automation).