[Resolved] LH1 Sending Delay

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 22:07 EDT

Monitoring

It looks like things have evened out. We are going to monitor for awhile. Behind the scenes, we've allocated more resources to this process to prevent future delays.
Posted Sep 05, 2025 - 16:04 EDT

Identified

Sending for some customers on LH1 has a slight delay, resulting in newsletters showing the "Sending" status for what seems longer than normal. This isn't a display issue. Our sending processing for these customers really has slowed. We are currently addressing the issue. Note that newsletters are going out, so don't try to resend if you think it's taking too long.
Posted Sep 05, 2025 - 13:36 EDT
This incident affected: Services (Email Service).