Investigating an incident with uploading an image
Incident Report for Letterhead
Resolved
The issue uploading an image has been resolved by our team, and all Letterhead services are now fully operational. We apologize for the inconvenience this incident may have caused and appreciate your patience while we worked to resolve it.

Letterhead is committed to providing the best possible service, and we continuously strive to improve.
Posted Mar 15, 2024 - 12:20 EDT
Investigating
Some customers are reporting an error message when uploading an image. Our team is actively investigating the incident and will update you with more information within an hour.

Please check our status page and subscribe to alerts for the most up-to-date information.
Posted Mar 15, 2024 - 11:56 EDT
This incident affected: Applications (Newsletters).