A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2026 - 12:57 EDT
Identified
We've identified the underlying issue. Letterhead has a map of Mailchimp's saved segments, but they can sometimes drift or diverge, which will signal errors. We are confirming this isn't meaningfully impacting the end-user experience and aligning on a patch solution. Thanks for your patience.
Posted Apr 01, 2026 - 12:04 EDT
Investigating
We have seen elevated errors surrounding Mailchimp campaign creation from within Letterhead. We are currently looking into it.
Posted Apr 01, 2026 - 11:53 EDT
This incident affected: Integrations (Mailchimp) and Applications (Newsletters).