Login issues for some users
Incident Report for Letterhead
Resolved
It appears the situation was temporary and that everybody should be able to log in.
Posted Jul 07, 2024 - 15:45 EDT
Monitoring
Some users are reporting an issue logging into Letterhead. The issue has been identified and service should be restored within the next few minutes. We will continue to monitor the situation.
Posted Jul 07, 2024 - 15:04 EDT
This incident affected: Applications (Audience, Composer, Dashboards, Promotions, Newsletters).