Temporarily slow email delivery
Incident Report for Letterhead
Resolved
We've resolved the latency and traffic is moving smoothly. Thank you for your patience.
Posted Apr 01, 2024 - 14:23 EDT
Monitoring
Some people have reported having published newsletters, but not yet seeing them in their inbox. Our team identified the cause: particularly high sending volume has caused some latency in our email delivery queue. Newsletters are sending successfully, they are just taking longer than usual to get through traffic. We will keep you updated.
Posted Apr 01, 2024 - 13:31 EDT
This incident affected: Services (Email Service Provider).