Most of our support channels in Slack have been reconnected, but there are still a few holdouts, so we are going to keep this status posted as a wayfinder for those affected users. Thanks for your understanding.
Posted Sep 13, 2026 - 19:07 EDT
Monitoring
Some of our shared Slack channels were disconnected as part of our upgrading to a higher tier, and while some were automatically reconnected, others weren't. For those, we are in the process of reconnecting. In the meantime, as you need anything, reach out through our support chat or at support@tryletterhead.com.
Posted Sep 13, 2026 - 08:37 EDT
This incident affects: Services (Customer Support and Ticketing).