We have resolved the underlying issue, which was a permissions problem. We will monitor for the time being and ensure things stay stable.
Posted May 22, 2025 - 15:04 EDT
Investigating
People are reporting that they are getting stuck on a white screen, that the application isn't loading for them after login. We are looking into this right now. No background service is affected. Thank you for your patience, and stay tuned.
Posted May 22, 2025 - 14:59 EDT
This incident affected: Applications (Archives, Audience, Composer, Dashboards, Promotions, Newsletters).