Test Email Latency

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 23, 2023 - 12:41 EDT

Monitoring

We have implemented a small patch that seems to resolve issues with latency. We'll monitor for awhile more but test emails should operate normally.
Posted Mar 23, 2023 - 11:56 EDT

Identified

We've identified the underlying issue and are working to improve this performance.
Posted Mar 23, 2023 - 11:27 EDT

Investigating

We are seeing reports from people experiencing issues sending Test emails to themselves. This doesn't affect the actual sending of newsletters, just tests. We are investigating.
Posted Mar 23, 2023 - 10:15 EDT
This incident affected: Applications (Newsletters).