Elevated RSS Feed Delays

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 13:51 EDT

Monitoring

RSS Feed Crawling delays continue to decline. We will move this into a "monitoring" status and continue to observe.
Posted Jun 11, 2026 - 13:19 EDT

Identified

Our RSS Feed Crawling is still experiencing some delays although error notifications are declining.
Posted Jun 11, 2026 - 12:52 EDT

Monitoring

We addressed the underlying issue and error rates are declining.
Posted Jun 11, 2026 - 12:46 EDT

Identified

We've largely uncovered the issue and are addressing it.
Posted Jun 11, 2026 - 11:50 EDT

Investigating

We have noticed a number of RSS Feed Error Notifications spike. We'll keep you posted.
Posted Jun 11, 2026 - 11:12 EDT
This incident affected: Services (Curation).