Ticketing Latency

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 15:36 EDT

Monitoring

Feature requests, questions, and bug reports are now getting where they need to go. We'll monitor for awhile longer.
Posted Aug 04, 2026 - 14:30 EDT

Identified

This likely doesn't affect many, but our internal service that takes a feature request or bug you report through Penpal is slower than usual. If anything's urgent, don't hesitate to talk to a person.
Posted Aug 04, 2026 - 13:45 EDT
This incident affected: Services (Customer Support and Ticketing).