Degraded Link Resolution and Enrichment

Incident Report for Letterhead

Resolved

We've resolved the issue and everything is hunky dory.
Posted Jun 28, 2026 - 14:17 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 28, 2026 - 13:58 EDT

Identified

We've noticed elevated errors with our click tracking service, which impact link content enrichment and consequently any downstream subscriber enrichment that results from those click tracking. This may also temporarily impact the links in prior emails sent before today, wherein the link times-out and doesn't consistently route traffic. Note: editions still have reliable click metrics, and links in all emails sent today (June 28) are resolving fine. The impact is low. Apologies for the hassle.
Posted Jun 28, 2026 - 13:55 EDT
This incident affected: Services (Link Resolution and Enrichment, Metrics).