Difficulty with scheduling reported
Incident Report for Letterhead
Resolved
All Letterhead services are now back to normal operation. The issue affecting users when scheduled has been resolved, and no new incidents have been reported.

We sincerely apologize for any inconvenience this incident may have caused to those impacted, and we appreciate your patience as we worked to resolve it.
Posted Apr 04, 2024 - 08:52 EDT
Monitoring
We have addressed the issue reported, and we will be monitoring closely throughout today. Please check our status page and subscribe to alerts for the most up-to-date information: Letterhead Status: https://letterhead.statuspage.io/

Please reach out to support if you require immediate assistance.
Posted Apr 03, 2024 - 11:27 EDT
Investigating
Some customers are reporting difficulty scheduling their newsletter, once they click 'Continue'. Our team is actively investigating the incident and will update you with more information within an hour.

Please check our status page and subscribe to alerts for the most up-to-date information: Letterhead Status: https://letterhead.statuspage.io/

Please reach out to support if you require immediate assistance.
Posted Apr 03, 2024 - 09:32 EDT
This incident affected: Applications (Composer, Newsletters).