Curations Sometimes Duplicating

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 07:13 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 01, 2026 - 19:52 EDT

Update

We will continue to monitor for several more hours, but so far so good.
Posted Apr 01, 2026 - 18:13 EDT

Monitoring

Things look pretty normal. We're going to monitor for awhile.
Posted Apr 01, 2026 - 14:49 EDT

Identified

We have observed elevated errors around curation creation and identified the underlying issue that may result in duplicate curations being created.
Posted Apr 01, 2026 - 14:00 EDT
This incident affected: Services (Curation).