DigitalOcean Outage
Incident Report for Letterhead
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 20:18 EDT
Update
It looks like things are back to normal, but we're going to hang around for awhile and make sure. Services restored.
Posted Jun 13, 2022 - 19:58 EDT
Monitoring
There is a DigitalOcean Outage as of 7:39 p.m. EST. https://status.digitalocean.com. We are monitoring and will have services back as soon as we can. Please direct questions to support@tryletterhead.com.
Posted Jun 13, 2022 - 19:43 EDT
This incident affected: Apps (Marketplace, Creator dashboard) and Services (API, Promotions, Promotions | Upstream).