Sidebar Navigation Issues

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 18:43 EDT

Identified

We've identified and already deployed a patch to address some issues with the sidebar menu in the main application, which is navigating people to pages that don't exist (a bad string interpolation). This ought to be addressed shortly.
Posted Sep 14, 2026 - 18:31 EDT