Unresponsive Composer Blocks

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 14:41 EDT

Monitoring

It looks like things are right as rain. We will continue to monitor.
Posted Sep 03, 2025 - 13:39 EDT

Identified

We've identified the issue. We should have the editor back in shape in a jiffy.
Posted Sep 03, 2025 - 13:22 EDT

Investigating

We are hearing and are able to replicate issues with the responsiveness of blocks in our newsletter editor, where engaging with them doesn't do anything. We're in the process of restoring behavior.
Posted Sep 03, 2025 - 13:13 EDT
This incident affected: Applications (Composer).