Microsoft-hosted Email Addresses Bouncing

Incident Report for Letterhead

Resolved

Microsoft has confirmed that they made additional changes the night of Thursday, Feb 26th that should have remediated most IP rate limiting and rejection issues.  If you are still seeing impacts, please reach out via your normal support channels and our team can investigate and escalate with Microsoft.
Posted Feb 27, 2026 - 13:25 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 26, 2026 - 14:26 EST

Monitoring

Microsoft is reporting elevated temporary rejection rates for emails delivered to Outlook.com, Hotmail, and other Microsoft-hosted addresses. They are actively investigating. This is an industry-wide issue and not isolated to a specific service or sender. We will continue to monitor and update this page as we receive more information.
Posted Feb 26, 2026 - 14:25 EST
This incident affected: Delivery (Outbound Email Deliverability (Shared Pools), Outbound Email Deliverability (Dedicated Pools)) and Services (Email Service Provider).