[Resolved] Organization Promotions not populating
Incident Report for Letterhead
Resolved
After monitoring, we believe everything to be resolved. Promotions should be loading normally. Thanks for your patience.
Posted Jan 08, 2024 - 14:28 EST
Monitoring
We think we've resolved the issue preventing newsletter promotion placement, and we will monitor for a short while to to confirm.
Posted Jan 08, 2024 - 13:47 EST
Identified
We believe we have identified the issue and are now in the process of resolving it.
Posted Jan 08, 2024 - 13:19 EST
Investigating
We have received reports that the promotions are not populating in the newsletter drafts. Our team is aware and reviewing the issue. As soon as we have more information, we will update the status page.
Posted Jan 08, 2024 - 13:11 EST
This incident affected: Applications (Promotions, Newsletters).