Inability to Login
Incident Report for Letterhead
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 09:47 EDT
Monitoring
We identified the underlying issue and you should able to log in. We'll monitor for awhile.
Posted Mar 16, 2023 - 09:13 EDT
Investigating
We've seen reports of folks unable to login. We are currently investigating and will update this page regularly.
Posted Mar 16, 2023 - 09:07 EDT
This incident affected: Applications (Archives, Audience, Promotions, Newsletters).