Degraded performance (Letterhead application slow to load)
Incident Report for Letterhead
Resolved
This incident has been resolved and performance has been returned to normal.
Posted Jul 24, 2024 - 19:43 EDT
Investigating
Our team has identified degraded performance of our application, and we are currently investigating. We will provide an update as soon as possible. Thank you in advance for your patience.
Posted Jul 24, 2024 - 15:29 EDT
This incident affected: Applications (Audience, Composer, Dashboards, Promotions, Newsletters).