Channel Settings Update Errors

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:57 EDT

Investigating

We are seeing an elevated error rate when changing channel settings, such as changing your channel description. We are investigating.
Posted Mar 23, 2026 - 14:52 EDT
This incident affected: Applications (Newsletters).