Investigating newsletter sending issues
Incident Report for Letterhead
Resolved
The issue has been resolved, which was with elevated latency in our sending queue. Performance returned to normal at about 2:00 p.m. EDT.

Letterhead is committed to providing the best possible service, and we continuously strive to improve. Thanks for your patience.
Posted Mar 22, 2024 - 16:22 EDT
Identified
Some customers are reporting difficulty sending newsletters. Our team has identified the cause and we are working through the fix.

Please check our status page and subscribe to alerts for the most up-to-date information: https://letterhead.statuspage.io/
Posted Mar 22, 2024 - 14:23 EDT
Update
We are continuing to investigate this issue.
Posted Mar 22, 2024 - 13:14 EDT
Investigating
Some customers are reporting difficulty sending newsletters. Our team is actively investigating the incident and will update you with more information within an hour.

Please check our status page and subscribe to alerts for the most up-to-date information: https://letterhead.statuspage.io/
Posted Mar 22, 2024 - 13:13 EDT
This incident affected: Services (Email Service Provider) and Applications (Composer, Newsletters).