[Resolved] Sent Newsletters Still Reporting as "Sending"

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 12:31 EDT

Monitoring

This has been resolved but we'll continue monitoring for awhile.
Posted Jul 13, 2026 - 11:48 EDT

Identified

We have identified and are addressing a display turnover issue where newsletters that are "Sending" have actually already been sent, but Letterhead hasn't updated the status. This prevents users from seeing their metrics.
Posted Jul 13, 2026 - 11:00 EDT
This incident affected: Applications (Newsletters) and Services (Metrics).