We deployed a patch and we are monitoring for further issues.
Posted May 06, 2026 - 15:25 EDT
Update
To those affected, thanks for your patience. This is difficult to replicate. We have ruled out that it's tied to any particular browser configuration, or user permissions on the Letterhead side of the coin, but is otherwise involving the auth handshake we're making with Google Oauth.
Posted May 06, 2026 - 14:04 EDT
Investigating
Users are inconsistently experiencing authorization issues when trying to import a letter from Google Docs.
Posted May 06, 2026 - 11:26 EDT
This incident affected: Integrations (Google Docs Integration).