Investigating automations outage
Incident Report for Letterhead
Resolved
The issue affecting automations has been resolved, and all Letterhead services are now fully operational. We apologize for the inconvenience this incident may have caused and appreciate your patience while we worked to resolve it.
Posted Dec 22, 2023 - 06:49 EST
Investigating
We’re currently experiencing an outage for our automations service. Our team is committed to providing you with excellent service and we are working to restore service as quickly as possible. We will provide an update within an hour.
Posted Dec 22, 2023 - 06:01 EST
This incident affected: Services (Email Service Provider) and Applications (Newsletters).