[Resolved] Elevated spam complaint in newsletter reports

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 13:47 EDT

Monitoring

We noticed that our system was incorrectly counting spam complaints for newsletters since June 12, causing reports to show newsletters with really high levels of spam complaints. This is essentially a display bug, which we already have patched, and we are now reprocessing those metrics to show the correct numbers. Thanks for your patience.
Posted Jul 15, 2025 - 12:22 EDT
This incident affected: Applications (Newsletters).