We are continuing to monitor for any further issues.
Posted Sep 21, 2026 - 14:06 EDT
Monitoring
we have begun restoring service, and we are seeing that emails are delivering. We are going to change the status of this outage to partial degradation, as it will be some time before all emails sent this morning arrive in inboxes. Thank you for your patience, and we will keep this status page current.
Posted Sep 21, 2026 - 13:41 EDT
Update
We are continuing to monitor and work closely with our providers.
Posted Sep 21, 2026 - 09:58 EDT
Update
We are continuing to address the underlying issue resulting in this outage. We have identified the problem and can confirm that, as of now, all your newsletters will go out, but they will be delayed. You do not need to resend or requeue anything if your newsletter shows that it is still sending or has been published. That status is correct, and we will ensure that everything goes out without duplicates.
Posted Sep 21, 2026 - 09:58 EDT
Identified
Unfortunately, we have identified an issue with an outage with an upstream provider that is affecting Letterhead's core deliverability services. Presently, you will experience some delays in your sending.
Posted Sep 21, 2026 - 08:34 EDT
This incident affected: Delivery (Outbound Email Deliverability (Shared Pools), Outbound Email Deliverability (Dedicated Pools)), Services (Authorization, Email Service Provider, Transactional Emails), API (Marketing API), and Applications (Newsletters).