We appreciate your patience. This status is likely to stay active for the rest of the afternoon and evening, but we can clarify the spike in delays are almost entirely centralized around Yahoo! mailboxes (and those that fall under its umbrella, AOL, etc.].
Posted Dec 26, 2025 - 16:06 EST
Monitoring
We are experiencing an increased relate of email delivery delays for newsletters sent to unengaged audiences and test audiences, which means that it may be several hours before newsletters are considered fully delivered to an entire list. These delays are affecting shared senders, and not audience members that Letterhead identifies as "engaged". If your list has a high percentage of unengaged recipients, you may experience delays in your newsletter metrics.
You do not have to do anything: don't resend your emails, these delays are fundamentally triggered by mailbox providers. Letterhead will continuously retry to deliver these emails automatically.
Posted Dec 26, 2025 - 11:52 EST
This incident affected: Delivery (Outbound Email Deliverability (Shared Pools)).