Audience Dashboard Visibility

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:56 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 27, 2026 - 13:27 EST

Investigating

We’re currently investigating reports of unexpected behavior across parts of the Letterhead application. Some users may experience issues with data visibility or functionality in certain areas of the app.
Posted Feb 27, 2026 - 12:26 EST
This incident affected: Applications (Audience).