Stripe payment processing temporarily unavailable
Incident Report for Letterhead
Resolved
This has been resolved (and we had resolved it a couple of hours ago, but failed to remove it from the status page). Thank you for your patience!
Posted Feb 22, 2024 - 18:25 EST
Identified
Payment processing through Stripe (for promotions and ad campaigns) is currently unavailable. Our team is working to restore payment service.
Posted Feb 22, 2024 - 14:11 EST
This incident affected: Services (Promotions API) and Applications (Promotions).