Our patch is deployed through the chrome web store and works like a dream. You may need to upgrade, but most Chromium browsers will automatically update.
Posted Apr 08, 2026 - 15:40 EDT
Identified
We have identified the underlying issue as one related to a prior incident (https://letterhead.statuspage.io/incidents/npm1z7nljgvb), which as part of addressing we introduced a misconfiguration with auth0 for some versions of the browser extension. We're are addressing this now through the chrome webstore, but we will be on google's timeline - so this incident may remain open for a bit.
Posted Apr 08, 2026 - 14:54 EDT
Investigating
There seems to be an issue affecting our browser extension (Letterhead for Chrome), where the extension is erroneously logging users out of their session. We are investigating the problem.
Posted Apr 08, 2026 - 14:18 EDT
This incident affected: Applications (Letterhead for Chrome).