Elevated transmission delays
Incident Report for Letterhead
Resolved
Things have been running smoothly for awhile now, so we will resolve this. Thank you for your patience.
Posted Oct 15, 2024 - 13:33 EDT
Update
It looks like newsletters are getting where they're supposed to go, so we're going to set the status to "operational" and keep monitoring for awhile longer.
Posted Oct 15, 2024 - 11:56 EDT
Monitoring
An upstream patch was implemented as early as 11:12 AM EST, and so we have just been monitoring and spot-checking on our end to ensure delivery is returning to normal.
Posted Oct 15, 2024 - 11:45 EDT
Identified
An upstream outage is impacting Letterhead's sending latency, and we are experiencing an elevated number of delays. Newsletters sent during this time might take extra long getting to their intended audience.
Posted Oct 15, 2024 - 11:09 EDT
This incident affected: Services (Email Service Provider).