Promotion Lookup with Elevated Errors

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 10:53 EDT

Identified

Good morning. We're addressing elevated error rates with Promotion lookups when loading promotions into templates or using the promotion calendar.
Posted Jul 28, 2026 - 09:08 EDT
This incident affected: Applications (Promotions).