HTML Block Validation Preventing Newsletter Publication

Incident Report for Letterhead

Postmortem

On January 22, 2026, some customers were temporarily unable to publish newsletters due to new HTML validation rules incorrectly flagging existing templates using HTML Blocks as invalid.

This issue was introduced as part of a recent update supporting enhanced HTML block functionality. While the update was intended to improve safety and flexibility for new use cases, it unintentionally affected a subset of existing templates that had previously published without issue.

The issue was identified quickly and fully resolved within the hour. No data was lost, and there was no service downtime.

What happened? We recently introduced additional HTML validation as part of a feature that allows teams to insert reusable HTML blocks across newsletters (for example, for tracking pixels or shared markup).

The intent of this validation was to prevent malformed or unsafe HTML from inadvertently breaking newsletter layouts when reused at scale. However, the new rules were stricter than previous behavior and did not fully account for certain valid HTML patterns already in use within existing templates.

As a result, some templates that had not changed were newly flagged as invalid, preventing editors from publishing.

We take reliability and trust seriously, especially when changes affect publishing workflows. We appreciate the patience of affected customers and are continuing to invest in safeguards that balance flexibility, safety, and backward compatibility.

If you have any questions or believe you were impacted, our support team is happy to help.

Posted Jan 22, 2026 - 19:05 EST

Resolved

Some customers were temporarily unable to publish newsletters due to new HTML validation rules incorrectly flagging existing templates using HTML Blocks as invalid.

This issue was introduced as part of a recent update supporting enhanced HTML block functionality. While the update was intended to improve safety and flexibility for new use cases, it unintentionally affected a subset of existing templates that had previously published without issue.
Posted Jan 22, 2026 - 11:30 EST