[Resolved] Missing "newsletters" menu item

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 09:44 EDT

Monitoring

The "newsletters" menu item should not be where you expect. We'll monitor for a bit.
Posted Jul 30, 2025 - 09:22 EDT

Identified

Some users are experiencing a missing "Newsletters" menu item, caused by a feature-flag issue. We have identified the cause and are addressing the issue now. Note: no automations or sending are affected, this is just a display issue.
Posted Jul 30, 2025 - 09:12 EDT
This incident affected: Applications (Newsletters).