We are able to confirm that we've resolved the underlying issue - but note that people will likely need to refresh their browser for the changes to take affect. We will monitor for awhile longer.
Posted Apr 15, 2026 - 12:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 12:12 EDT
Update
Apologies for the radio silence. A patch is deploying that ought to resolve the underlying issue. When confirmed we will update the status.
Posted Apr 15, 2026 - 11:55 EDT
Identified
We've identified issues with users cloning newsletters, which affects the use of newsletter templates, where they are told "unfortunately, we weren't able to clone this newsletter." We are addressing the issue now.
Posted Apr 15, 2026 - 10:18 EDT
This incident affected: Applications (Newsletters).