Shared Pool Delivery Delays

Incident Report for Letterhead

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 17:14 EDT

Monitoring

Delays are reducing in number and we are continuing to monitor.
Posted Jul 13, 2026 - 14:42 EDT

Identified

We've identified the underlying issue and we are actively noodling. Thanks for your patience.
Posted Jul 13, 2026 - 14:20 EDT

Investigating

We are seeing elevated system reports of delivery delays, which may result in an email arriving in someone's inbox later than expected.
Posted Jul 13, 2026 - 13:40 EDT
This incident affected: Delivery (Outbound Email Deliverability (Shared Pools)).