Archives Elevated Server Errors

Incident Report for Letterhead

Postmortem

We encountered an issue that prevented new newsletters from displaying properly in our public archive. While the newsletters themselves were delivered as usual, readers saw a blank page instead of the newsletter content in the archive. The underlying cause was a recent change we made to improve performance, which inadvertently affected how those pages were displayed.

We quickly identified the problem and implemented a fix within about three hours. We’re also updating our testing processes to ensure this doesn’t happen again. We apologize for any inconvenience and appreciate your understanding as we continue to improve your experience.

Posted Sep 24, 2025 - 17:09 EDT

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 17:08 EDT

Monitoring

Archives server errors have returned to normal levels (that being: almost none).
Posted Sep 24, 2025 - 17:00 EDT

Identified

We are still noticing elevated levels of server errors, even though archives appear to resolve. We're going to reset this back to "identified" until server errors decline
Posted Sep 24, 2025 - 16:26 EDT

Monitoring

Apologies for the wait. All newsletter archives seem to be humming along. We'll monitor for awhile.
Posted Sep 24, 2025 - 16:23 EDT

Update

We are testing our patch and should restore things shortly. Note that this isn't affecting entire newsletter archives, but certain newsletters written relatively recently. They are still resolving for the purposes of SEO.
Posted Sep 24, 2025 - 15:25 EDT

Identified

We have identified the underlying issue and are in the process of restoring the service. Thanks for your patience.
Posted Sep 24, 2025 - 13:59 EDT

Investigating

We are seeing that the web version of newsletters are resolving to a white screen. We apologize for the hassle and we will keep you updated.
Posted Sep 24, 2025 - 13:42 EDT
This incident affected: Applications (Archives).